Wednesday, May 29, 2013

More guiding work

Doug Munday on the CelestronCGEM Yahoo! group helped me to analyze my PHD logs more to understand what's going on.

First of all, he pointed me to PHDLab - a log analyzer for PHD.

The good news is that with the work of the last few weeks, my guiding accuracy improved from 10 pixels peak error down to 4.7 pixels peak error (imaging pixels - not guiding pixels). That's good, but I should be able to get it down more.

Doug thinks that it is mostly external events that impact my guiding (because most of the time, RA and DEC at the same time need to correct large values and because there were some intervals were guiding was much better). A couple of thoughts:
Furthermore, he recommends that I set RA max duration to 2000 and that I should set RA backlash to 0. The latest hardware for the mount motors can't deal with backlash in DEC and in RA.

With that, I got my errors down to 3.83 (combined peak) or 1.11 (combined RMS). I can now take 10 min exposures and keep the stars pretty tight. That's awesome!

Three things still make me concerned:
  1. One thing that I didn't notice before is that when PHD calibrates DEC, the star doesn't move for the first 1-2 exposures, then it moves. When PHD switches direction, the star continues to move for 1-2 exposures into the first direction. Then it stops, but never moves back. I suspect that this started after I set DEC backlash correction to 0.
  2. Also, I can still see that a couple of times, the DEC axis correction tends upwards until at some point it drops. It seems as if I should allow PHD to make larger corrections faster. Is that something that I could improve by switching the DEC algorithm to "Lowpass filter"? Though I read somewhere that this setting doesn't work yet.
  3. When slewing in RA, the mount is making some "sounds". Not the clicking sounds that I heard after hypertuning the mount, but some sounds that  don't sound "smooth". That can't be good!!
On the CelestronCGEM Yahoo! group I received some useful feedback:
  1. It's normal that you don't see any movement in the second step of the DEC calibration. It's a little weird, that my mount seems to move longer into the first direction though.
  2. I tried the "Lowpass filter" option, but that lead to several runaway guides, i.e. where PHD had to apply more and more correction in the DEC direction but never caught up. I stopped that experiment.
Interestingly, the DEC error is not consistently small then the RA error:
DEC: 1.8 peak, 0.4 RMS (arcsec)
RA: 2.2 peak, 0.6 RMS (arcsec)

Next I will try if periodic error correction can help me to reduce my RA errors more.