Saturday, September 14, 2013

New Focuser

Somehow the Robofocus controllbox broke - can't use it manually anymore, can't use it remotely anymore...

I was pretty annoyed by Robofocus (too many cables, fragile cables, the bulky motor construction in the back of my scope, backlash) anyway. So, I used this as an opportunity to switch to a MicroTouch controlled Feather Touch focuser. The other advantage of this is that I have a great manual focuser if the motor or motor control fails.

I ordered it from Starizona and it arrived some 10 days later (if you order Starizona, don't try to use their order status to understand the status of your order - it doesn't get updated!)

Installation was a breeze. First I installed the Feather Touch focuser, then I removed the turning nobs and installed the MicroTouch focuser on top. Took me a little over an hour! And now I have just a little knob back there and not the whole Robofocuser arm!
The red circle shows the focuser + motor. Compare this to the clunky Robofocus arm in this post.

Next, I wanted to install the MicroTouch control software and ASCOM driver. Installing the MicroTouch control software was easy. But I could not use the ASCOM driver - I always got this error message when I tried to select the MicroTouch focuser in the ASCOM chooser:
"Incompatible Driver (microtouch.focuser)
This driver is not registered for COM (can't find ProgID), please reinstall."

I tried various combinations:

  • Installing the MicroTouch control program first or later
  • Installing the driver as admin or not
  • Disabling User Account Control
Nothing. Mailed Dean from Starizona and received the following instructions:

Make sure you run the installation MicroTouchUSB2 setup by right clicking and running as admin.  Then run the MicroTouch the application not the setup itself by right clicking and run as admin (required first time only).

Did that - and now I could use it from SGPro!!! Yei!
But not from TheSkyX :-( I could select not the MicroTouch focuser in the ASCOM control box, but couldn't click "OK" (it was disabled). When I selected "Settings" - I always got an exception.

Searched the TheSkyX forum and found this post: I downloaded the zip file mentioned which contained a native driver for the MicroTouch focuser.

After I installed it, I had a "Starizona" entry in the focuer chooser dialog. But when I selected it, I received another error message.

... strangely enough, when I went back to the Ascom focuser and chose MicroTouch focuser in it's chooser, it worked (the only strange thing was that I got a popup asking me if I have a USB or USB2 controller - and that popup box opened BEHIND TheSkyX). Well, I take it!!!

Next, I played with the automatic focusing routing in SGPro. I got really weird results: my graph always looked very flat with some ups and downs. Took me a while to realize that the step size is set by default to 1, i.e. there is VERY little focuser movement compared to the Robofocus (where I had set the step size to 8!). The MicroTouch focuser has 60000 steps. I.e. with a step size of 1, I won't be able to move the focus all the way in and out - but I pretty much never need that anyway. So, I cold keep this step size and allow for very small adjustments (could be handy when I image with the hyperstar lens which has a very small critical focus zone) or I could set it to a higher value and allow for wider range.

And then I wanted to train the temperature compensation. From the manual, it looked VERY easy: focus, start training, wait until the temperature drops, focus again, stop training. Now I have a compensation ratio that the MicroTouch controller would apply automatically when the temperature changes.
... but the temperature did not change during training! Well, it went a little bit up and down, but it did not change significantly. And I started the training at 9pm and waited until midnight - and it was definitively cooler then.