Thursday, July 31, 2014

Focuser Slip! Replacing my Robofocus with a FLI Atlas focuser

After I installed (and aligned) the new camera, I wanted to calibrate the filter. Especially the focus difference of the individual filters (so that I can use the Luminance filter for autofocusing and then switch to another filter). But when I did that, I noticed that I got very inconsistent results. In particular, it looks as if the focus position got smaller and smaller. But not by 1 or 2 positions (which could be explained by it cooling down during the night). No, by 100 postions or more between runs.

After more investigation, I realized that the focuser was severely slipping under the load. I read a lot about this that the Takahashi focuser together with the Robofocuse focuser could slip - though before I didn't experience this. So, I need a new focuser...

After some research I found two:

1. FLI Atlas focuser
2. Feathertouch focuser

The Atlas focuser is more then twice as expensive. But I also read that the Feathertouch focuser could slip under heavy load. Plus in order to user the Feathertouch focuser I would have to completely remove the stock focuser - and with that the guiderscope platform that I used for my guidescope.

I then tried to figure out how to integrate the FLI Atlas focuser. Most straight forward would be to just move the Takahashi focuser all the way in and put it between the Takahashi focuser and the reducer/flattener. But in order to gain focus, I have to extend the focuser less then an inch:

That would not be enough for the Atlas focuser which is a little less then 2 inches thick.

I tried to figure out how to integrate it otherwise. Two options came up:

1. Remove the entire stock focuser and have a custom adapter from preciseparts build that attaches directly to the optical tube. It would have the advantage that it will make the scope significantly lighter (removing the entire focuser and just replacing it with an empty tube). But it would also have the disadvantage that I would have to reconfigure my guidescope.

2. Remove just the rotator at the end of the focuser. The rotator adds ~1.7 inches, i.e. without it and by moving the stock focuser all the way in, I could integrate the Atlas focuser. And I could keep my guidescope where it is.

I decided to try #2. But removing the rotator was quite the task. I first removed the focuser from the scope:

I then locked the rotator down (I had to severely tighten then rotator screw) and with a strap wrench I could get it off:

But now came the next challenge: the thread at the end of the drawtube was NOT a 92mm thread - but a 98mm! Apparently, Takahashi has a 98->92mm downstep ring. I am trying to order this.

In the meantime, I am using the Flattener which requires a longer focus distance. I put the rotator back on the focuser, put the Atlas focuser on it, then the flattener and then the imaging train. As the Atlas focuser has a fairly short drawtube, I tried to get rough focus with the Takahashi focuser and then locked it down.

I then used SGPro to get focus. I had to set the focuser step size to 1000 (which is the maximum!)- and even with that, I needed more then 20 data points to create a good V-shape curve. As soon as I had everything calibrated, focusing worked really well.

One problem was that it took me a few attempts to connect the focuser and a few times the autofocus routine hanged when it had to move the focuser out. I asked on the SGPro forum about it - will need to get an Ascom debug file to help investigating it. The next night, I chose "ASCOM chooser" and everything worked without a problem. Strange!

But the focuser itself is just awesome - positions super exact, no slip, no sagging!