Friday, October 3, 2014

Using my Nikon D7000 (again)

I decided to use my Nikon D7000 for astro imaging again:
  1. For images where I don't need to use long exposures, e.g. the moon (in preparation for the lunar eclipse in October!)
  2. To mount the Nikon on top of the scope to take wide angle images while imaging with my CCD cameras.
First, I had to dig out my Shoestring DSUBS adapter (long time ago that I used that). I could mount it well on my dovetail on top of the scope. Then I had to figure out (again) how to connect it. First I tried with DSLR Shutter (that's what I used MANY months ago, i.e. it should work). I could connect, but it didn't trigger the shutter. Found this post on the shoestring forum that explains it:
  1. Plug in the box to the computer, then the other cable from the box to your camera.
  2. Set DSLR Shutter to use the DSUSB if it doesn't automatically find it, then under the file menu select "AF during exposure (Nikon D200)", trust me on this one.
  3. If you want to use the mirror lockup feature (why wouldn't you?) make sure that is checked on the main DSLR Shutter screen.
  4. Set your D7000 for M mode (top left dial), then Mup mode (dial just below the top left dial), then rotate the top rear thumb dial until you see BULB, lastly make sure you move the focus selector to M (left front of the camera near the bottom).
With that it worked - including the mirror lockup feature. Yei! But then I realized that I can't do subsecond exposures with DSLR Shutter. So, it would work for long term exposures but not for the moon :-(

For imaging simultaneously with the Nikon and a CCD camera, I ordered a Camera mount from ADM. I will put it also on top of the Losmandy dovetail - right over mount, so that the additional weight does not impact guiding accuracy.


For imaging through the scope, I needed a new adapter from preciseparts to go from the 92mm Takahashi thread to a t-thread. Luckily I noticed just before ordering it, that the Nikon camera is not flat and that the 92mm size barrel would not fit if it's too snug. So, I dug out some of my t extensions and ordered a slightly shorter adapter. With that, the camera fit perfectly.

Then I tried to connect to it from SGPro. First attempts didn't work. At some point, I read the error message which said that I should remove the SD card ... and with that, I could connect. Tried to take an image: SGPro triggered the exposure correctly. But then hung when it tried to download the image. I tried various things (all image settings, <30 second exposures with native exposure and >30 sec exposures with bulb) - always the same result. Asked for help on the SGPro forum.

Next, I checked if I could use TheSkyX - but it can only connect to Canon DSLR cameras.

Finally, I dug out Nikon Camera Control Pro. But it only showed a "No camera was detected" error message when I tried to connect. Looked around and found tons of complaints. But nobody seemed to have a good solution...

One post pointed to ControlMyNikon - tried that one. After some trial and testing, I got it to work! Including Live View!!!